summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 17:49:11 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 11:41:59 +0100
commitb1c6fe0ff4bd4b91229bb912c032f8792f6eb9ce (patch)
tree1f371c0e69fab58e8644bebb0de1e9e83c89ee66 /dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
parentdev-ros/ament_cmake_core: initial import (diff)
downloadgentoo-b1c6fe0ff4bd4b91229bb912c032f8792f6eb9ce.tar.gz
gentoo-b1c6fe0ff4bd4b91229bb912c032f8792f6eb9ce.tar.bz2
gentoo-b1c6fe0ff4bd4b91229bb912c032f8792f6eb9ce.zip
dev-ros/ament_cmake_libraries: initial import
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild')
-rw-r--r--dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild b/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
new file mode 100644
index 000000000000..927b7ae06922
--- /dev/null
+++ b/dev-ros/ament_cmake_libraries/ament_cmake_libraries-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+DESCRIPTION="The core of the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+
+src_configure() {
+ # This is a build tool that does not install python-related files
+ # ... but we need to propagate the deps and use python3 to build it.
+ local pyimpl="${PYTHON_COMPAT[0]}"
+ python_export "${pyimpl}" EPYTHON PYTHON
+ python_wrapper_setup
+ cmake-utils_src_configure
+}