summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 12:49:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 13:09:22 +0200
commit6781eac38ee25fd1cfd6d78c7e72c40e8591bce5 (patch)
tree62401acbb9472810bb5284901aa4981c476df161 /dev-ros/ament_cmake_python/ament_cmake_python-1.0.1.ebuild
parentdev-ros/ament_cmake_libraries: bump to 1.0.1 (diff)
downloadgentoo-6781eac38ee25fd1cfd6d78c7e72c40e8591bce5.tar.gz
gentoo-6781eac38ee25fd1cfd6d78c7e72c40e8591bce5.tar.bz2
gentoo-6781eac38ee25fd1cfd6d78c7e72c40e8591bce5.zip
dev-ros/ament_cmake_python: bump to 1.0.1
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_python/ament_cmake_python-1.0.1.ebuild')
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-1.0.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-1.0.1.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-1.0.1.ebuild
new file mode 100644
index 000000000000..866ed8213865
--- /dev/null
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to use Python in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+PATCHES=( "${FILESDIR}/destdir.patch" )
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}