summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 21:22:50 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 21:35:30 +0100
commit485de1672254ab88537c6d1964bd8f0e3b99eb3f (patch)
treee3160cd0da47ee197d45ce6778616ec655f44126 /dev-ros/ament_cmake_python
parentdev-ros/ament_cmake_libraries: bump to 1.0.3 (diff)
downloadgentoo-485de1672254ab88537c6d1964bd8f0e3b99eb3f.tar.gz
gentoo-485de1672254ab88537c6d1964bd8f0e3b99eb3f.tar.bz2
gentoo-485de1672254ab88537c6d1964bd8f0e3b99eb3f.zip
dev-ros/ament_cmake_python: bump to 1.0.3
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cmake_python')
-rw-r--r--dev-ros/ament_cmake_python/Manifest1
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_python/Manifest b/dev-ros/ament_cmake_python/Manifest
index d4bd850b64bf..1dc2a3ed13a7 100644
--- a/dev-ros/ament_cmake_python/Manifest
+++ b/dev-ros/ament_cmake_python/Manifest
@@ -1,3 +1,4 @@
DIST ament_cmake-0.9.6.tar.gz 60800 BLAKE2B 71c4e71c50b7715bb8f1b5b737ce23e30f79459a14a5866801bcb810b8fe82d807b6a4eae11de427f52c618e14ef22b7693905f1a0200cc38f0ffab1d70e80cd SHA512 c923260bbd0142ea57bf3e868e94e76020939e8ec49cbf23f14221d0048f21efed00dcdae9978e00f246725ba216c151f5d53b1cd94297b8731f53dc0e45b554
DIST ament_cmake-1.0.0.tar.gz 63304 BLAKE2B dd0c4bc5b72d9143cfb8ee9caae236a3608981ee8523e879ea9c168d64fd1d0cb84e54679cfc0cfc58ffff34519bb1032afc956c3130c1da8b4f98d60a9191be SHA512 69236015368df29a128eceeb64dd1c683eb32a44188b52120592238f999be8c8c7c5892a36ddcef48b6686bf97eba77e820ca3b8896c64ec1522661fa3ed4fc7
DIST ament_cmake-1.0.1.tar.gz 66465 BLAKE2B cd905b52f4600ccf364ab8d5e4dcf102e1f6034bae7ab020022860fa440ff058a996752cbb0e743b5f66a2b6bc0d1f46cec7c71900be53f035ed8a0642e50b04 SHA512 5f60c933c0ba1eea97f2d0913e19f383e154f26a0625ea4e40c529dd1fa5831109f7cbc0c39a514d37334d61c5d614df0ea546e49ab46202002af09a2adf6288
+DIST ament_cmake-1.0.3.tar.gz 67279 BLAKE2B 5a11fd6e8174a47acc2f7524c8aec4ce0b77668525928d722c631b6d874d8d7229a84e5dd084eda834d5afcdf4cc1faf692c3ea4552374b0858c2b60610417e6 SHA512 654a02d8c8130d023d063eff29197ed71e75a1f46c73e3808f5e481ce1b68ff6d0b3002b471bb3ba13a473c4947f4a291cc91cf1aa803906d3a89c78e66eb76a
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild
new file mode 100644
index 000000000000..7f0a525558f8
--- /dev/null
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to use Python in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+PATCHES=( "${FILESDIR}/destdir.patch" )
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}