summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-04 13:17:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-05 13:31:47 +0200
commit41c363099f9f34042ca8470ecabfee3ae4627921 (patch)
tree7d0162670304a700bed27e8936398126d6bc3864 /dev-ros/ament_copyright
parentdev-ros/ament_lint: bump to 0.11.2 (diff)
downloadgentoo-41c363099f9f34042ca8470ecabfee3ae4627921.tar.gz
gentoo-41c363099f9f34042ca8470ecabfee3ae4627921.tar.bz2
gentoo-41c363099f9f34042ca8470ecabfee3ae4627921.zip
dev-ros/ament_copyright: bump to 0.11.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_copyright')
-rw-r--r--dev-ros/ament_copyright/Manifest1
-rw-r--r--dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-ros/ament_copyright/Manifest b/dev-ros/ament_copyright/Manifest
index e3cb32d3e524..e2ea8fb7f8b4 100644
--- a/dev-ros/ament_copyright/Manifest
+++ b/dev-ros/ament_copyright/Manifest
@@ -1 +1,2 @@
DIST ament_lint-0.10.4.tar.gz 222285 BLAKE2B 81a15dc996bad0fe3fa461aa7067eba423550d94a04881a12c8a4b0732a4a0ddcc30ab6bef94f81cb236836d8de7959b53d5560d5fb6eb480f2fbd849bd02489 SHA512 cb99084622f598b17f1ffe55620c9c822867771f2603e673098f8943d95b7be188e25480d4e22bf7c2988e94d8b69f6f7fa3b60cd042213f6bd8c2ad2c5deaf3
+DIST ament_lint-0.11.2.tar.gz 265435 BLAKE2B 09545bd029dc692e5393983a3fc9210600c4a6456635238b7038ff87799f9cfde9c2d3c7ceb4c01b71594ba7bd159e8b6b3c2370bdfcdbf3d6189a895b96292a SHA512 1a379f4fb0ead306a668aef2b9e390728d6d3901b75f43fac6ccc28681a8010e42b094237f3f1ab95ca304ba917c8fb5d5519ec0581cadb346e6eb05466e39f0
diff --git a/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild b/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild
new file mode 100644
index 000000000000..dfdc3192ac68
--- /dev/null
+++ b/dev-ros/ament_copyright/ament_copyright-0.11.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check source files for copyright and license information."
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}