summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-06 10:39:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-06 11:30:52 +0200
commit2d766cd38d6f6303f01afeaf8e59e839f4659da1 (patch)
treec2c4dd6d36f7bc63305f9ae93490e852a61db5f4 /dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
parentdev-ros/ament_xmllint: bump to 0.10.4 (diff)
downloadgentoo-2d766cd38d6f6303f01afeaf8e59e839f4659da1.tar.gz
gentoo-2d766cd38d6f6303f01afeaf8e59e839f4659da1.tar.bz2
gentoo-2d766cd38d6f6303f01afeaf8e59e839f4659da1.zip
dev-ros/ament_cppcheck: bump to 0.10.4
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild')
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
new file mode 100644
index 000000000000..7749ef3ab532
--- /dev/null
+++ b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to perform static code analysis on C/C++ code using Cppcheck"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-util/cppcheck
+"
+DEPEND=""
+BDEPEND=""