summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 16:12:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 16:12:22 +0200
commit86244c4e5de81b00e41c692782a5214fbee82673 (patch)
tree72224b48294fdf962590c81bd858b9b01082c9ea /dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
parentdev-ros/ament_cppcheck: Remove old (diff)
downloadgentoo-86244c4e5de81b00e41c692782a5214fbee82673.tar.gz
gentoo-86244c4e5de81b00e41c692782a5214fbee82673.tar.bz2
gentoo-86244c4e5de81b00e41c692782a5214fbee82673.zip
dev-ros/ament_cppcheck: py improvments
add py39/310 enable but restrict tests Closes: https://bugs.gentoo.org/798621 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild')
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
index 2dbf9430dfe6..1ec0564cee82 100644
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
+++ b/dev-ros/ament_cppcheck/ament_cppcheck-0.10.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -36,3 +36,8 @@ RDEPEND="
"
DEPEND=""
BDEPEND=""
+
+# pytest.ini is there but no tests are ran causing it to fail
+RESTRICT="test"
+
+distutils_enable_tests pytest