summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-03 16:01:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-03 16:12:21 +0200
commitc5566b0759e89abc79fc8e73143f450ec3978929 (patch)
treec6a87cccbeb2ff85b557f8d1b57c3b19fca060c3 /dev-ros/ament_lint
parentdev-ros/ament_lint: Remove old (diff)
downloadgentoo-c5566b0759e89abc79fc8e73143f450ec3978929.tar.gz
gentoo-c5566b0759e89abc79fc8e73143f450ec3978929.tar.bz2
gentoo-c5566b0759e89abc79fc8e73143f450ec3978929.zip
dev-ros/ament_lint: python improvements
add py39 & 310 setup distutils dep properly enable but restrict tests Closes: https://bugs.gentoo.org/798624 Closes: https://bugs.gentoo.org/803005 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_lint')
-rw-r--r--dev-ros/ament_lint/ament_lint-0.10.4-r1.ebuild (renamed from dev-ros/ament_lint/ament_lint-0.10.4.ebuild)7
-rw-r--r--dev-ros/ament_lint/ament_lint-9999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/dev-ros/ament_lint/ament_lint-0.10.4.ebuild b/dev-ros/ament_lint/ament_lint-0.10.4-r1.ebuild
index ea29b12dcd48..8c8bff8aecc0 100644
--- a/dev-ros/ament_lint/ament_lint-0.10.4.ebuild
+++ b/dev-ros/ament_lint/ament_lint-0.10.4-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -33,3 +34,7 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
BDEPEND=""
+# pytest.ini is there but no tests are ran causing it to fail
+RESTRICT="test"
+
+distutils_enable_tests pytest
diff --git a/dev-ros/ament_lint/ament_lint-9999.ebuild b/dev-ros/ament_lint/ament_lint-9999.ebuild
index ea29b12dcd48..8c8bff8aecc0 100644
--- a/dev-ros/ament_lint/ament_lint-9999.ebuild
+++ b/dev-ros/ament_lint/ament_lint-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python{3_8,3_9,3_10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -33,3 +34,7 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
BDEPEND=""
+# pytest.ini is there but no tests are ran causing it to fail
+RESTRICT="test"
+
+distutils_enable_tests pytest