summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 13:01:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 13:09:30 +0200
commitd351d3dec1b034f66eb7125c5a77225d3fc1062f (patch)
tree5b5b9674db19154f784f7647265db139fc08d750 /dev-ros/ament_uncrustify
parentdev-ros/ament_cmake_cpplint: bump to 0.10.0 (diff)
downloadgentoo-d351d3dec1b034f66eb7125c5a77225d3fc1062f.tar.gz
gentoo-d351d3dec1b034f66eb7125c5a77225d3fc1062f.tar.bz2
gentoo-d351d3dec1b034f66eb7125c5a77225d3fc1062f.zip
dev-ros/ament_uncrustify: bump to 0.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_uncrustify')
-rw-r--r--dev-ros/ament_uncrustify/Manifest1
-rw-r--r--dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/ament_uncrustify/Manifest b/dev-ros/ament_uncrustify/Manifest
index 6b51d9c9d13e..8dd9c04fcb27 100644
--- a/dev-ros/ament_uncrustify/Manifest
+++ b/dev-ros/ament_uncrustify/Manifest
@@ -1 +1,2 @@
+DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384
diff --git a/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild b/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild
new file mode 100644
index 000000000000..fa3b285d2836
--- /dev/null
+++ b/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against style conventions using uncrustify"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-util/uncrustify
+"
+DEPEND=""
+BDEPEND=""