summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-30 13:00:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-30 13:09:28 +0200
commit920a852407c8c0eeb0573662fae6ca0b0af95d23 (patch)
treee5e828ab34db791b060bf703abc036947834cfd6 /dev-ros/ament_xmllint/ament_xmllint-0.10.0.ebuild
parentdev-ros/ament_lint_cmake: bump to 0.10.0 (diff)
downloadgentoo-920a852407c8c0eeb0573662fae6ca0b0af95d23.tar.gz
gentoo-920a852407c8c0eeb0573662fae6ca0b0af95d23.tar.bz2
gentoo-920a852407c8c0eeb0573662fae6ca0b0af95d23.zip
dev-ros/ament_xmllint: bump to 0.10.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_xmllint/ament_xmllint-0.10.0.ebuild')
-rw-r--r--dev-ros/ament_xmllint/ament_xmllint-0.10.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ros/ament_xmllint/ament_xmllint-0.10.0.ebuild b/dev-ros/ament_xmllint/ament_xmllint-0.10.0.ebuild
new file mode 100644
index 000000000000..d9b72688ca3b
--- /dev/null
+++ b/dev-ros/ament_xmllint/ament_xmllint-0.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Checks XML files like the package manifest using xmllint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest