summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-01 12:28:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-01 12:39:01 +0200
commitff5bb7d91d2fb36f065a450fe368184c3022aaa3 (patch)
tree41ac8f0f87af1583b7cbd3fc332f744211135a75 /dev-ros/audio_play/audio_play-0.3.1.ebuild
parentdev-ros/audio_common_msgs: Bump to 0.3.1. (diff)
downloadgentoo-ff5bb7d91d2fb36f065a450fe368184c3022aaa3.tar.gz
gentoo-ff5bb7d91d2fb36f065a450fe368184c3022aaa3.tar.bz2
gentoo-ff5bb7d91d2fb36f065a450fe368184c3022aaa3.zip
dev-ros/audio_play: Bump to 0.3.1.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/audio_play/audio_play-0.3.1.ebuild')
-rw-r--r--dev-ros/audio_play/audio_play-0.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/audio_play/audio_play-0.3.1.ebuild b/dev-ros/audio_play/audio_play-0.3.1.ebuild
new file mode 100644
index 000000000000..88882f9cd47c
--- /dev/null
+++ b/dev-ros/audio_play/audio_play-0.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/audio_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Outputs audio to a speaker from a source node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/audio_common_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ media-libs/gstreamer:1.0
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-base:1.0
+"