summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:52:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:02:05 +0200
commit6fdec862640ae24ffcca2d5e99ac50e8b5daa445 (patch)
treea188212ffae09f3e33e2733215fbb796555b5b56 /dev-ros/base_local_planner/base_local_planner-9999.ebuild
parentdev-ros/carrot_planner: Remove old (diff)
downloadgentoo-6fdec862640ae24ffcca2d5e99ac50e8b5daa445.tar.gz
gentoo-6fdec862640ae24ffcca2d5e99ac50e8b5daa445.tar.bz2
gentoo-6fdec862640ae24ffcca2d5e99ac50e8b5daa445.zip
dev-ros/base_local_planner: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/base_local_planner/base_local_planner-9999.ebuild')
-rw-r--r--dev-ros/base_local_planner/base_local_planner-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-ros/base_local_planner/base_local_planner-9999.ebuild b/dev-ros/base_local_planner/base_local_planner-9999.ebuild
index b9d3cfb7e498..b157b88b7158 100644
--- a/dev-ros/base_local_planner/base_local_planner-9999.ebuild
+++ b/dev-ros/base_local_planner/base_local_planner-9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
CATKIN_HAS_MESSAGES=yes
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
inherit ros-catkin
-DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to local robot navigation on a plane"
+DESCRIPTION="Trajectory Rollout and Dynamic Window approaches to robot navigation on a plane"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -21,22 +20,24 @@ RDEPEND="
>=dev-ros/costmap_2d-1.16
dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
dev-cpp/eigen:3
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
>=dev-ros/nav_core-1.16
dev-ros/pluginlib
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2
- dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2_ros
- dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/voxel_grid
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}
- dev-ros/cmake_modules
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-ros/rosunit[${PYTHON_USEDEP}] )
"
+BDEPEND="
+ dev-ros/cmake_modules
+"