summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:13:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:13:45 +0200
commit983e0808673c96d624eddbba61a6064743cb6a4a (patch)
tree116cc4c3a299ac4934b13f1f1435bc0da0a5d5b7 /dev-ros/bondcpp/bondcpp-1.7.16.ebuild
parentdev-ros/smclib: Initial import. Ebuild by me. (diff)
downloadgentoo-983e0808673c96d624eddbba61a6064743cb6a4a.tar.gz
gentoo-983e0808673c96d624eddbba61a6064743cb6a4a.tar.bz2
gentoo-983e0808673c96d624eddbba61a6064743cb6a4a.zip
dev-ros/bondcpp: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/bondcpp/bondcpp-1.7.16.ebuild')
-rw-r--r--dev-ros/bondcpp/bondcpp-1.7.16.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/bondcpp/bondcpp-1.7.16.ebuild b/dev-ros/bondcpp/bondcpp-1.7.16.ebuild
new file mode 100644
index 000000000000..68f68325bd45
--- /dev/null
+++ b/dev-ros/bondcpp/bondcpp-1.7.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond
+ dev-ros/cmake_modules
+ dev-ros/roscpp
+ dev-ros/smclib
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"