summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:04:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:25 +0200
commit94428c91abca799d0644af830a58ec669801b871 (patch)
treed4de3a46a5962c206e4f102bf7c452e303db9f5d /dev-ros/bondcpp/bondcpp-1.8.5.ebuild
parentdev-ros/bond: Bump to 1.8.5. (diff)
downloadgentoo-94428c91abca799d0644af830a58ec669801b871.tar.gz
gentoo-94428c91abca799d0644af830a58ec669801b871.tar.bz2
gentoo-94428c91abca799d0644af830a58ec669801b871.zip
dev-ros/bondcpp: Bump to 1.8.5.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/bondcpp/bondcpp-1.8.5.ebuild')
-rw-r--r--dev-ros/bondcpp/bondcpp-1.8.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/bondcpp/bondcpp-1.8.5.ebuild b/dev-ros/bondcpp/bondcpp-1.8.5.ebuild
new file mode 100644
index 000000000000..faf7108d4d5e
--- /dev/null
+++ b/dev-ros/bondcpp/bondcpp-1.8.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond
+ dev-ros/cmake_modules
+ >=dev-ros/roscpp-1.13.6
+ dev-ros/smclib
+ dev-libs/boost:=
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"