summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 14:22:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 14:55:56 +0100
commit6aa0db9ab6b1bc250f2b85acece0b235f16b5886 (patch)
treea4f4978e77d92d2c163ba7bb0d65631fe7317be1 /dev-ros/bondpy/bondpy-1.7.17.ebuild
parentdev-ros/bondcpp: Bump to 1.7.17. (diff)
downloadgentoo-6aa0db9ab6b1bc250f2b85acece0b235f16b5886.tar.gz
gentoo-6aa0db9ab6b1bc250f2b85acece0b235f16b5886.tar.bz2
gentoo-6aa0db9ab6b1bc250f2b85acece0b235f16b5886.zip
dev-ros/bondpy: Bump to 1.7.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/bondpy/bondpy-1.7.17.ebuild')
-rw-r--r--dev-ros/bondpy/bondpy-1.7.17.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/bondpy/bondpy-1.7.17.ebuild b/dev-ros/bondpy/bondpy-1.7.17.ebuild
new file mode 100644
index 000000000000..abb50962dc64
--- /dev/null
+++ b/dev-ros/bondpy/bondpy-1.7.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python implementation of bond, a mechanism for checking when another process has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bond[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/smclib
+ sys-apps/util-linux
+"
+DEPEND="${RDEPEND}"