summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-24 16:25:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-25 14:37:21 +0200
commitd89088e19e169b1d9c6d0bc77e967f3d20f04d18 (patch)
treeb25f49b443431e4d2754e63eec3c57fb1c69a963 /dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
parentdev-ros/camera_calibration: fix tests (diff)
downloadgentoo-d89088e19e169b1d9c6d0bc77e967f3d20f04d18.tar.gz
gentoo-d89088e19e169b1d9c6d0bc77e967f3d20f04d18.tar.bz2
gentoo-d89088e19e169b1d9c6d0bc77e967f3d20f04d18.zip
dev-ros/calibration_estimation: fix tests
Closes: https://bugs.gentoo.org/738482 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
index c83819a9fef4..d24d3f651478 100644
--- a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
@@ -37,3 +37,8 @@ src_prepare() {
sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
2to3 -w src/*/*.py src/*/*/*.py test/*.py || die
}
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}