summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-05 16:54:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-05 17:30:09 +0200
commitee2d2c671a98dfd61e61b1525975b1cfce94f160 (patch)
tree5727c6ac015d4f9b46c03beaa807d6c06658f55c /dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
parentdev-ros/camera_calibration: prefetch test data (diff)
downloadgentoo-ee2d2c671a98dfd61e61b1525975b1cfce94f160.tar.gz
gentoo-ee2d2c671a98dfd61e61b1525975b1cfce94f160.tar.bz2
gentoo-ee2d2c671a98dfd61e61b1525975b1cfce94f160.zip
dev-ros/calibration_estimation: fix py3 compat
Closes: https://bugs.gentoo.org/734710 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
index 804aef9eae27..c83819a9fef4 100644
--- a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
@@ -30,3 +30,10 @@ DEPEND="${RDEPEND}
dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
+PATCHES=( "${FILESDIR}/py3.patch" )
+
+src_prepare() {
+ ros-catkin_src_prepare
+ sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
+ 2to3 -w src/*/*.py src/*/*/*.py test/*.py || die
+}