summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 15:59:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commit6cbb9692eb7cddf6462f76a2146049db8fec4ef5 (patch)
tree6987e8be47d87a2113b641dc77f583e835a860b7 /dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
parentdev-ros/image_cb_detector: Initial import. Ebuild by me. (diff)
downloadgentoo-6cbb9692eb7cddf6462f76a2146049db8fec4ef5.tar.gz
gentoo-6cbb9692eb7cddf6462f76a2146049db8fec4ef5.tar.bz2
gentoo-6cbb9692eb7cddf6462f76a2146049db8fec4ef5.zip
dev-ros/calibration_estimation: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-9999.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
new file mode 100644
index 000000000000..b6c1e6fcd36f
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-libs/urdfdom[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"