summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-10 16:51:26 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-10 18:34:45 +0100
commitc175c64c788bc53fa0a23749de011938a78eabbd (patch)
tree84f0b87f854e6c9a9fb6b00daec8763759162eab /dev-ros/camera_calibration/camera_calibration-1.13.0.ebuild
parentsci-electronics/gazebo: fix build with openal 1.20 (diff)
downloadgentoo-c175c64c788bc53fa0a23749de011938a78eabbd.tar.gz
gentoo-c175c64c788bc53fa0a23749de011938a78eabbd.tar.bz2
gentoo-c175c64c788bc53fa0a23749de011938a78eabbd.zip
dev-ros/camera_calibration: Bump to 1.13.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/camera_calibration/camera_calibration-1.13.0.ebuild')
-rw-r--r--dev-ros/camera_calibration/camera_calibration-1.13.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration/camera_calibration-1.13.0.ebuild b/dev-ros/camera_calibration/camera_calibration-1.13.0.ebuild
new file mode 100644
index 000000000000..dffb8eec336f
--- /dev/null
+++ b/dev-ros/camera_calibration/camera_calibration-1.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of monocular or stereo cameras using a checkerboard calibration target"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/image_geometry[${PYTHON_USEDEP}]
+ || ( media-libs/opencv[python,${PYTHON_USEDEP}] media-libs/opencv[python,python_single_target_python2_7] )
+ dev-ros/message_filters[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"