summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-30 15:18:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-03-30 15:18:48 +0200
commit110ac5e97ee4c58b40cd3e1e7e6491fffd0fec02 (patch)
treea95a4ac1d45bfca1b317c1c0769fc639f8ffbd77 /dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13-r1.ebuild
parentdev-ros/camera_calibration_parsers: Remove old (diff)
downloadgentoo-110ac5e97ee4c58b40cd3e1e7e6491fffd0fec02.tar.gz
gentoo-110ac5e97ee4c58b40cd3e1e7e6491fffd0fec02.tar.bz2
gentoo-110ac5e97ee4c58b40cd3e1e7e6491fffd0fec02.zip
dev-ros/camera_calibration_parsers: add := dep on yaml-cpp
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13-r1.ebuild')
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13-r1.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13-r1.ebuild
new file mode 100644
index 000000000000..5b75e5e3a185
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.11.13-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ >=dev-cpp/yaml-cpp-0.5:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/nose )
+"
+PATCHES=( "${FILESDIR}/boostpython.patch" )