summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:09:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:13 +0200
commit5439ad49e0e19118283f333ace34d59ba4c32c15 (patch)
tree6fd0602d202e3b4a138bb4f632d04cc9a0540eb0 /dev-ros/camera_calibration_parsers
parentros-meta/image_common: Bump to 1.12.0. (diff)
downloadgentoo-5439ad49e0e19118283f333ace34d59ba4c32c15.tar.gz
gentoo-5439ad49e0e19118283f333ace34d59ba4c32c15.tar.bz2
gentoo-5439ad49e0e19118283f333ace34d59ba4c32c15.zip
dev-ros/camera_calibration_parsers: update patch
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/camera_calibration_parsers')
-rw-r--r--dev-ros/camera_calibration_parsers/files/boostpython.patch8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-ros/camera_calibration_parsers/files/boostpython.patch b/dev-ros/camera_calibration_parsers/files/boostpython.patch
index 02019d6458f7..30840401c0df 100644
--- a/dev-ros/camera_calibration_parsers/files/boostpython.patch
+++ b/dev-ros/camera_calibration_parsers/files/boostpython.patch
@@ -5,15 +5,11 @@ Index: camera_calibration_parsers/CMakeLists.txt
===================================================================
--- camera_calibration_parsers.orig/CMakeLists.txt
+++ camera_calibration_parsers/CMakeLists.txt
-@@ -4,11 +4,7 @@ project(camera_calibration_parsers)
+@@ -4,7 +4,7 @@ project(camera_calibration_parsers)
find_package(catkin REQUIRED sensor_msgs rosconsole roscpp roscpp_serialization)
find_package(PythonLibs REQUIRED)
--if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
-- find_package(Boost REQUIRED COMPONENTS filesystem python)
--else()
-- find_package(Boost REQUIRED COMPONENTS filesystem python3)
--endif()
+-find_package(Boost REQUIRED COMPONENTS filesystem python)
+find_package(Boost REQUIRED COMPONENTS filesystem python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})