summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:03:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:12 +0200
commitce0705d0fbd762fba7f9607c9c11c9536338d519 (patch)
tree701273189d31c52d0a1dc06ef1827e424304fa9f /dev-ros/camera_calibration_parsers
parentdev-ros/camera_calibration_parsers: bump eapi (diff)
downloadgentoo-ce0705d0fbd762fba7f9607c9c11c9536338d519.tar.gz
gentoo-ce0705d0fbd762fba7f9607c9c11c9536338d519.tar.bz2
gentoo-ce0705d0fbd762fba7f9607c9c11c9536338d519.zip
dev-ros/camera_calibration_parsers: Bump to 1.12.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/camera_calibration_parsers')
-rw-r--r--dev-ros/camera_calibration_parsers/Manifest1
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration_parsers/Manifest b/dev-ros/camera_calibration_parsers/Manifest
index 484244f8631f..bc60da42ce06 100644
--- a/dev-ros/camera_calibration_parsers/Manifest
+++ b/dev-ros/camera_calibration_parsers/Manifest
@@ -1 +1,2 @@
DIST image_common-1.11.13.tar.gz 54731 BLAKE2B 24c05d7da79ec4edc1713eb86efe9d570b8a9d55def1b0cdf7959275c4a0692af28d48d37d73361f3972c0f4ded5332ee02b535f1841473007eb8e61287b7826 SHA512 154a1acfc3ee1be83828f7b86de8a5e02d7613d724f734409c5b93b1505bcf911b95f20fe43435932f49e03e286ed7055e2b7abeb1c5292f540a2299dd424bfa
+DIST image_common-1.12.0.tar.gz 56174 BLAKE2B c364c060f4ba025b8811514602df934c028f39e22089c3dbaa71be3db891d7a769ecbe0c58c683128d1111ff377530aa6de8c48ede35f8b39301717ce581526c SHA512 bdd382b676673459ee28bd63ca695db893099796e8b025dd9519c7e07061a7dc0f62cd76f72b0d73aebec063c512c03fd420ab5f3982a7496409863826a2aeb0
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild
new file mode 100644
index 000000000000..50bf5757a10b
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ >=dev-cpp/yaml-cpp-0.5:=
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+PATCHES=( "${FILESDIR}/boostpython.patch" )