summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:25:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commitf50af997104ddc2397df4731bc2feb3440fb2e25 (patch)
tree40dc97d94c45ea40ac320a348cc842bb29f7fee8 /dev-ros/carrot_planner/carrot_planner-9999.ebuild
parentdev-ros/base_local_planner: Initial import. Ebuild by me. (diff)
downloadgentoo-f50af997104ddc2397df4731bc2feb3440fb2e25.tar.gz
gentoo-f50af997104ddc2397df4731bc2feb3440fb2e25.tar.bz2
gentoo-f50af997104ddc2397df4731bc2feb3440fb2e25.zip
dev-ros/carrot_planner: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/carrot_planner/carrot_planner-9999.ebuild')
-rw-r--r--dev-ros/carrot_planner/carrot_planner-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/carrot_planner/carrot_planner-9999.ebuild b/dev-ros/carrot_planner/carrot_planner-9999.ebuild
new file mode 100644
index 000000000000..adf49edf5b94
--- /dev/null
+++ b/dev-ros/carrot_planner/carrot_planner-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to find a legal place to put a carrot for the robot to follow"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/base_local_planner
+ dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"