summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:47:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit8f4f4cd528c47b4af93ebccf6da3554cdc58495c (patch)
tree32838418ab584b54ca87e29719f384b18e2456c2 /dev-ros/clear_costmap_recovery/clear_costmap_recovery-9999.ebuild
parentdev-ros/carrot_planner: Initial import. Ebuild by me. (diff)
downloadgentoo-8f4f4cd528c47b4af93ebccf6da3554cdc58495c.tar.gz
gentoo-8f4f4cd528c47b4af93ebccf6da3554cdc58495c.tar.bz2
gentoo-8f4f4cd528c47b4af93ebccf6da3554cdc58495c.zip
dev-ros/clear_costmap_recovery: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/clear_costmap_recovery/clear_costmap_recovery-9999.ebuild')
-rw-r--r--dev-ros/clear_costmap_recovery/clear_costmap_recovery-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/clear_costmap_recovery/clear_costmap_recovery-9999.ebuild b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-9999.ebuild
new file mode 100644
index 000000000000..2a32da63e50d
--- /dev/null
+++ b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts to clear space by reverting the costmaps to the static map"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-cpp/eigen:3
+ sci-libs/pcl
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest dev-cpp/gtest )
+"