summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-24 09:30:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-24 09:31:58 +0200
commit601de1ac088b73df07c11d2609ac4f92530a8084 (patch)
tree047ecce856136f15af183bca952fb7c294ef4fdd /dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.11.0.ebuild
parentdev-ros/combined_robot_hw: initial import; ebuild by me (diff)
downloadgentoo-601de1ac088b73df07c11d2609ac4f92530a8084.tar.gz
gentoo-601de1ac088b73df07c11d2609ac4f92530a8084.tar.bz2
gentoo-601de1ac088b73df07c11d2609ac4f92530a8084.zip
dev-ros/combined_robot_hw_tests: initial import; ebuild by me
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.11.0.ebuild')
-rw-r--r--dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.11.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.11.0.ebuild b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.11.0.ebuild
new file mode 100644
index 000000000000..26912cde9438
--- /dev/null
+++ b/dev-ros/combined_robot_hw_tests/combined_robot_hw_tests-0.11.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/combined_robot_hw
+ dev-ros/controller_manager
+ dev-ros/controller_manager_tests
+ dev-ros/hardware_interface
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"