summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-09 09:43:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-09 09:43:42 +0100
commit401639fd958bd68ff207bd958400c56f41ed2392 (patch)
treee739444bae658afa547eb14e323f3e55098020ce /dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
parentnet-misc/putty: x86 stable wrt bug #565080 (diff)
downloadgentoo-401639fd958bd68ff207bd958400c56f41ed2392.tar.gz
gentoo-401639fd958bd68ff207bd958400c56f41ed2392.tar.bz2
gentoo-401639fd958bd68ff207bd958400c56f41ed2392.zip
dev-ros/compressed_depth_image_transport: Set PYTHON_COMPAT and PYTHON_USEDEP for dynamic reconfigure. Bug #565156.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild')
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
index 51e86fe70e03..26ea9b623897 100644
--- a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
@@ -6,6 +6,7 @@ EAPI=5
ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -16,7 +17,7 @@ IUSE=""
RDEPEND="
dev-ros/cv_bridge
- dev-ros/dynamic_reconfigure
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
dev-ros/image_transport
dev-ros/tf
media-libs/opencv