summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:06:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:06:41 +0200
commit94c1d43a733631b9218c60e5014aaa0f169314fc (patch)
treef53a9a402f38946e5ce54e1e735d814a2e9412fc /dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
parentros-meta/image_pipeline: Initial import. Ebuild by me. (diff)
downloadgentoo-94c1d43a733631b9218c60e5014aaa0f169314fc.tar.gz
gentoo-94c1d43a733631b9218c60e5014aaa0f169314fc.tar.bz2
gentoo-94c1d43a733631b9218c60e5014aaa0f169314fc.zip
dev-ros/compressed_depth_image_transport: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild')
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
new file mode 100644
index 000000000000..51e86fe70e03
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ dev-ros/tf
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}"