summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 11:44:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 12:45:50 +0200
commit7fb48ab859835f6edc60af15a31ba9c566c7c673 (patch)
tree279af1b1abbc848a80fbf2da77af299a10bbf1dd /dev-ros/compressed_depth_image_transport
parentdev-ros/timestamp_tools: bump eapi (diff)
downloadgentoo-7fb48ab859835f6edc60af15a31ba9c566c7c673.tar.gz
gentoo-7fb48ab859835f6edc60af15a31ba9c566c7c673.tar.bz2
gentoo-7fb48ab859835f6edc60af15a31ba9c566c7c673.zip
dev-ros/compressed_depth_image_transport: Bump to 1.14.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/compressed_depth_image_transport')
-rw-r--r--dev-ros/compressed_depth_image_transport/Manifest1
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/compressed_depth_image_transport/Manifest b/dev-ros/compressed_depth_image_transport/Manifest
index e2eda7adac3c..9162d0af9256 100644
--- a/dev-ros/compressed_depth_image_transport/Manifest
+++ b/dev-ros/compressed_depth_image_transport/Manifest
@@ -1 +1,2 @@
+DIST image_transport_plugins-1.14.0.tar.gz 28803 BLAKE2B fc3fc34c0dc01c5dc0ed7f2a88fd691f9b955009bbf91a2280e39455e0325a46edc67c25cf79d8e4882789c20235c13fb87bfc64669ffda40a1fe37224a346e9 SHA512 1333f18a3208ecda4f788dc2d974b5787a89d33a1ad1ea2c6b4cc07593c677686aa5e9df3346d2e5f307699b88b42f341a989eebecc3cd7885768e3dcdbbcdcb
DIST image_transport_plugins-1.9.5.tar.gz 26268 BLAKE2B 2d7e71f891bc3ae548193a9671fb10fb4dc6c7a24fda0c0dc52d75d43793d55e35da37155496740624e4ebe34fcf0e8d3926345ca1581fa521096c01b773f551 SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0.ebuild
new file mode 100644
index 000000000000..8486f37df36a
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.14.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"