summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-18 13:45:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-18 14:13:24 +0200
commit425af2ead1c2562771ef6e556336ddff394b4f4f (patch)
tree28ebef7be19ed7b5a48804635ffb0b24b1094635 /dev-ros/depth_image_proc/depth_image_proc-1.12.18.ebuild
parentdev-ros/camera_calibration: Bump to 1.12.18. (diff)
downloadgentoo-425af2ead1c2562771ef6e556336ddff394b4f4f.tar.gz
gentoo-425af2ead1c2562771ef6e556336ddff394b4f4f.tar.bz2
gentoo-425af2ead1c2562771ef6e556336ddff394b4f4f.zip
dev-ros/depth_image_proc: Bump to 1.12.18.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/depth_image_proc/depth_image_proc-1.12.18.ebuild')
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-1.12.18.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/depth_image_proc/depth_image_proc-1.12.18.ebuild b/dev-ros/depth_image_proc/depth_image_proc-1.12.18.ebuild
new file mode 100644
index 000000000000..99fb96f964f9
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-1.12.18.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}"