summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-12-28 18:52:27 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-12-28 20:10:31 +0100
commitb5b2aad43b9427b756c9131fac4f2208689744ef (patch)
tree56ce06ea343fd903fc51be03b458e84dfa36a93b /dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild
parentdev-ros/depth_image_proc: Remove old (diff)
downloadgentoo-b5b2aad43b9427b756c9131fac4f2208689744ef.tar.gz
gentoo-b5b2aad43b9427b756c9131fac4f2208689744ef.tar.bz2
gentoo-b5b2aad43b9427b756c9131fac4f2208689744ef.zip
dev-ros/depth_image_proc: add missing := dep on console bridge
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild')
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild b/dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild
new file mode 100644
index 000000000000..65c78ae415a8
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"