summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:13:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:29 +0200
commit299287544331d542a80630589c58c3f86138213d (patch)
tree0203ad0a2dbe6d729287c36923ea0da95cc875b4 /dev-ros/depth_image_proc
parentdev-ros/camera_calibration: Bump to 1.15.2. (diff)
downloadgentoo-299287544331d542a80630589c58c3f86138213d.tar.gz
gentoo-299287544331d542a80630589c58c3f86138213d.tar.bz2
gentoo-299287544331d542a80630589c58c3f86138213d.zip
dev-ros/depth_image_proc: Bump to 1.15.2.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/depth_image_proc')
-rw-r--r--dev-ros/depth_image_proc/Manifest1
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-1.15.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/depth_image_proc/Manifest b/dev-ros/depth_image_proc/Manifest
index ac6a860a5299..ad2d85c190b2 100644
--- a/dev-ros/depth_image_proc/Manifest
+++ b/dev-ros/depth_image_proc/Manifest
@@ -1,3 +1,4 @@
DIST image_pipeline-1.12.22.tar.gz 139237 BLAKE2B 9c4ad324494f7e9db935cceed562840bb7ed7af730655398c9ac410722faf7d6747010ef0bbee55f14b555b6b2a6756de3edde31d84c3ae3fad123cea4a85bfe SHA512 34c17bd13625dc0a3c94639ce5ea17cc7674b0035b425c10020178d08037fb4fd081a84d7e83c75822f58c0ba2faead351702dbbc75c821d2f8c17bda351c560
DIST image_pipeline-1.12.23.tar.gz 139986 BLAKE2B 22349762d6119a2246cb812cce310ebe98b046881ea1192425c4a0ebd7717b8e2768cd4f357ebf905f81e2be9816b7b864ee1040e570d156f9377f51386274a1 SHA512 cb9df1845ae3e7a08788e8f401b8e1b5354cc06f9a4b1aa62d2729c5d84033adbc0049a837236644a0b89951a172b230d4c074bc403bb265ba6cf0ad8016dbdd
DIST image_pipeline-1.13.0.tar.gz 143194 BLAKE2B 618f95271196e37126f158e3454ffb81b1543af1fd87db281f6b8ec00bcf37a812139063318b576c7d39cde7828fc45e3caec24fcbb3e6b4a047d16907427ad2 SHA512 91aeb8e7a14090679e639a65de434c51e8d67f9a9c53bde69f9a5b4f3ae64e5fb1470baf5d2ba33debd2f46cd1699cf69bec53ef2160ea405c46c0e19bb3c3af
+DIST image_pipeline-1.15.2.tar.gz 147570 BLAKE2B 7e6ecad344e38426148017c4bdd109cdb505201256b811d7479b2fa5f2b6a94f94708ffd0e2a3c273f09fb8db0afdedb6955320bc142e4b48fbf94eeef45b453 SHA512 8fe9fa7759d83b2585589c6667c82b154c6ab748aa1644e8a58c75550e4c581fdea1b42f91a8c64df4eb7a06b33a76e55325268f314f3ec1f06ee38ee7b06bfc
diff --git a/dev-ros/depth_image_proc/depth_image_proc-1.15.2.ebuild b/dev-ros/depth_image_proc/depth_image_proc-1.15.2.ebuild
new file mode 100644
index 000000000000..560850540f29
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-1.15.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"