summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 19:11:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:46 +0200
commitd6788074d5b35a489f12f23d1a188e3d4ff71314 (patch)
tree51054d44362b6049aeae81228270446cef82a5e3 /dev-ros/depthimage_to_laserscan
parentdev-ros/driver_base: bump eapi (diff)
downloadgentoo-d6788074d5b35a489f12f23d1a188e3d4ff71314.tar.gz
gentoo-d6788074d5b35a489f12f23d1a188e3d4ff71314.tar.bz2
gentoo-d6788074d5b35a489f12f23d1a188e3d4ff71314.zip
dev-ros/depthimage_to_laserscan: bump to 1.0.8
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/depthimage_to_laserscan')
-rw-r--r--dev-ros/depthimage_to_laserscan/Manifest1
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.8.ebuild28
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild12
3 files changed, 35 insertions, 6 deletions
diff --git a/dev-ros/depthimage_to_laserscan/Manifest b/dev-ros/depthimage_to_laserscan/Manifest
index 15e1be05a2a3..07324772c72f 100644
--- a/dev-ros/depthimage_to_laserscan/Manifest
+++ b/dev-ros/depthimage_to_laserscan/Manifest
@@ -1 +1,2 @@
DIST depthimage_to_laserscan-1.0.7.tar.gz 12121 BLAKE2B f8b69ce10311e39eaf963c42fd6ea653c8b0fe1c2381ab128d575d490d236b03d8667a213e8e9eb9423c4a9244697fb9746ebe8385ac0142776e47063fe9e5bf SHA512 4da5fa446d574dbb44c2924dd760f160e527e68d7df119e5d9e74d85efd3473ee31845e8565b0d023d2cf22c945b3b5c56b12a04facd4e38dc3dd1235dad73e9
+DIST depthimage_to_laserscan-1.0.8.tar.gz 12189 BLAKE2B 78668e8768bf9f402b5d94af71045677ce35b9b680c1b298f48a8a0c55f3920880eef24d0ab334150b967fd1378b9e4ada8069965057238e59116adb2f803d32 SHA512 50472016630d10b5a8544c7a2391c215de307dc5b0d8445cdc05d8e2f251651221bf18b18e389d000adacf79324569bb6ad7a23c6c6cce901d5ae1c966b4533d
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.8.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.8.ebuild
new file mode 100644
index 000000000000..77f0689a0e7f
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/isnan.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
index 2e621e904b7b..77f0689a0e7f 100644
--- a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -20,9 +19,10 @@ RDEPEND="
dev-ros/image_geometry
dev-ros/image_transport
dev-ros/nodelet
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-libs/boost:=
dev-libs/console_bridge:=
"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+PATCHES=( "${FILESDIR}/isnan.patch" )