summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:00:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:24 +0200
commit90c26fdf502aa2931c6faf0e8f88cbc61be682f4 (patch)
tree33e6eb252af7ba75332698e6c09fda825cf81908 /dev-ros/diagnostic_updater
parentdev-ros/rosdiagnostic: Remove old (diff)
downloadgentoo-90c26fdf502aa2931c6faf0e8f88cbc61be682f4.tar.gz
gentoo-90c26fdf502aa2931c6faf0e8f88cbc61be682f4.tar.bz2
gentoo-90c26fdf502aa2931c6faf0e8f88cbc61be682f4.zip
dev-ros/diagnostic_updater: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/diagnostic_updater')
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild9
-rw-r--r--dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild11
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild
index 99d9f927c224..ca0ceb79a286 100644
--- a/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-1.9.4.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -15,11 +14,13 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/roscpp
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/std_msgs[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild b/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
index 11ea335900e4..ca0ceb79a286 100644
--- a/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
+++ b/dev-ros/diagnostic_updater/diagnostic_updater-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -15,11 +14,13 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/roscpp
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/std_msgs[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"