summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:19:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:19:49 +0200
commitabe19cec009a4d77bc8452db0a6d6fa6eb07ee54 (patch)
tree278c8daf39c92a1a51de8014d8bea2b9ce710a6f /dev-ros/driver_base/driver_base-9999.ebuild
parentdev-ros/moveit_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-abe19cec009a4d77bc8452db0a6d6fa6eb07ee54.tar.gz
gentoo-abe19cec009a4d77bc8452db0a6d6fa6eb07ee54.tar.bz2
gentoo-abe19cec009a4d77bc8452db0a6d6fa6eb07ee54.zip
dev-ros/driver_base: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/driver_base/driver_base-9999.ebuild')
-rw-r--r--dev-ros/driver_base/driver_base-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/driver_base/driver_base-9999.ebuild b/dev-ros/driver_base/driver_base-9999.ebuild
new file mode 100644
index 000000000000..1cf5d1f88dd9
--- /dev/null
+++ b/dev-ros/driver_base/driver_base-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Framework for writing drivers that helps with runtime reconfiguration, diagnostics and self-test"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"