summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-11 05:42:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-11 05:42:18 +0200
commit3d6f06b21d098a56f7f5ca4fd5a485540b71d195 (patch)
tree4901d695a8a20cbfc6e7eb1ca549cb76b94f2eb8 /dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild
parentdev-ros/filters: Bump to 1.8.0 (diff)
downloadgentoo-3d6f06b21d098a56f7f5ca4fd5a485540b71d195.tar.gz
gentoo-3d6f06b21d098a56f7f5ca4fd5a485540b71d195.tar.bz2
gentoo-3d6f06b21d098a56f7f5ca4fd5a485540b71d195.zip
dev-ros/dynamic_reconfigure: Bump to 1.5.48
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild')
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild
new file mode 100644
index 000000000000..9650a1395bcb
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"