summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-23 08:45:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-23 09:30:31 +0200
commit992431d9bc6b34fd4dbe8b051e76bf9348b24c8c (patch)
treec10e05eb6334ce40d7f866ede617650626171eb8 /dev-ros/fake_localization/fake_localization-1.15.1.ebuild
parentdev-ros/dwa_local_planner: Bump to 1.15.1. (diff)
downloadgentoo-992431d9bc6b34fd4dbe8b051e76bf9348b24c8c.tar.gz
gentoo-992431d9bc6b34fd4dbe8b051e76bf9348b24c8c.tar.bz2
gentoo-992431d9bc6b34fd4dbe8b051e76bf9348b24c8c.zip
dev-ros/fake_localization: Bump to 1.15.1.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ros/fake_localization/fake_localization-1.15.1.ebuild')
-rw-r--r--dev-ros/fake_localization/fake_localization-1.15.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/fake_localization/fake_localization-1.15.1.ebuild b/dev-ros/fake_localization/fake_localization-1.15.1.ebuild
new file mode 100644
index 000000000000..8f5fc1286c21
--- /dev/null
+++ b/dev-ros/fake_localization/fake_localization-1.15.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/angles
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+"
+DEPEND="${RDEPEND}"