summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-04 20:36:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-04 20:46:33 +0200
commit865d742c1c1d0bf5752054817c5dff8c34916b3b (patch)
tree078b9676786bb2ee0ae39a0c4941c78b94f5320b /dev-ros/fake_localization/fake_localization-1.16.2.ebuild
parentdev-ros/dwa_local_planner: Bump to 1.16.2. (diff)
downloadgentoo-865d742c1c1d0bf5752054817c5dff8c34916b3b.tar.gz
gentoo-865d742c1c1d0bf5752054817c5dff8c34916b3b.tar.bz2
gentoo-865d742c1c1d0bf5752054817c5dff8c34916b3b.zip
dev-ros/fake_localization: Bump to 1.16.2.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/fake_localization/fake_localization-1.16.2.ebuild')
-rw-r--r--dev-ros/fake_localization/fake_localization-1.16.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/fake_localization/fake_localization-1.16.2.ebuild b/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
new file mode 100644
index 000000000000..0c7895911491
--- /dev/null
+++ b/dev-ros/fake_localization/fake_localization-1.16.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/angles
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/message_filters
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"