summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:31:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:35 +0200
commit54bcbec753ad7d91f8542ebf2fd506edc4a26ac4 (patch)
tree148063f3d2e587bfe32da473dfa50fc0b302f6b3 /dev-ros/fake_localization
parentdev-ros/dwa_local_planner: Bump to 1.17.1. (diff)
downloadgentoo-54bcbec753ad7d91f8542ebf2fd506edc4a26ac4.tar.gz
gentoo-54bcbec753ad7d91f8542ebf2fd506edc4a26ac4.tar.bz2
gentoo-54bcbec753ad7d91f8542ebf2fd506edc4a26ac4.zip
dev-ros/fake_localization: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/fake_localization')
-rw-r--r--dev-ros/fake_localization/Manifest1
-rw-r--r--dev-ros/fake_localization/fake_localization-1.17.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/fake_localization/Manifest b/dev-ros/fake_localization/Manifest
index a4fee98c8c5a..494e2eda7805 100644
--- a/dev-ros/fake_localization/Manifest
+++ b/dev-ros/fake_localization/Manifest
@@ -1 +1,2 @@
DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
+DIST navigation-1.17.1.tar.gz 349192 BLAKE2B 4cb946a296ab53d7196a70c66cc1dda0cf62f5f279fe020ca7c39781ecb5402af6addcd6164ab6e0a9bcfe3ba26e42f647546280f03b572202f0f4df8d6ed3cf SHA512 23178adaef9b720c644f621c67ed579be312101e70a7d12b527164c5cc55286982c99149a521a76c6dda05248e859435e51f9a0f09e582b89aed3b7c2173cfaa
diff --git a/dev-ros/fake_localization/fake_localization-1.17.1.ebuild b/dev-ros/fake_localization/fake_localization-1.17.1.ebuild
new file mode 100644
index 000000000000..532a449c1399
--- /dev/null
+++ b/dev-ros/fake_localization/fake_localization-1.17.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/angles
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/message_filters
+"
+DEPEND="${RDEPEND}
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"