summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:49:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:42 +0200
commit9474c2234f5a6736829a4f96cd7d607a1d39bbd2 (patch)
treebf8ebad938cbae826bed1038cdb20e5cb3863166 /dev-ros/gazebo_ros
parentdev-ros/gazebo_plugins: Bump to 2.9.1. (diff)
downloadgentoo-9474c2234f5a6736829a4f96cd7d607a1d39bbd2.tar.gz
gentoo-9474c2234f5a6736829a4f96cd7d607a1d39bbd2.tar.bz2
gentoo-9474c2234f5a6736829a4f96cd7d607a1d39bbd2.zip
dev-ros/gazebo_ros: Bump to 2.9.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/gazebo_ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.9.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index af68829371ed..0aaaa62cbdc3 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -5,3 +5,4 @@ DIST gazebo_ros_pkgs-2.7.4.tar.gz 1839281 BLAKE2B 3a8342465e69c6b7d986b6a9f04b42
DIST gazebo_ros_pkgs-2.8.4.tar.gz 1853755 BLAKE2B 4551557629cb43e651714b2e1a6aca3b127cd769bad47144b1fb769138f5c15cee45ab012a6e695559f42dbd7b0989984a2c979abc8779f63f815f909ec4a411 SHA512 6595e06b1269e2cdf8850a040f40e59a9169cc0790e7b646ba025767a72fc4eabcacd069d1cd3f82b1ca66ff47811df117134323a10e409aa2fe8b9c1f812525
DIST gazebo_ros_pkgs-2.8.5.tar.gz 1854305 BLAKE2B f82021144b788b5fe19269ad28e1970a5f932ec91f7afdc0e45c4870125138b51cfadd794c08b52836f21e9d07c026cda80656794201b606b11b344ae73847e8 SHA512 124af0cff7933ce61127fd3ea61261e94b154954586af420c78775a6e4c69a741402aa563cb8d12a6b0f8a794a3948533c0a01555b00546c7c89742e43b25666
DIST gazebo_ros_pkgs-2.8.7.tar.gz 1860830 BLAKE2B 2d0bf4774b1eff0bc658baf101d3450e5d94bcf8603a6e012b8a62422eb6a6b32e3c00c82f2854182ff990cf5017c23dac02d645c6a634d9fdb34403870ffd20 SHA512 3326c88dd7145a5beeaa0bd9c19f6abc2fb5483cfff1748b01c8f137c7223ffef80ff0df5cd0a2cb255006eaa44eef60cc878b362eed4a1d9a43a1a09ad24eaa
+DIST gazebo_ros_pkgs-2.9.1.tar.gz 1861740 BLAKE2B 56569e73184c767abeea0ac6add8aa19bb70e66f3a41fe9fc5278e540759de945467372c7a0130acdb665924ab803defa22e148a36a624d08c39835dc110e208 SHA512 47510f97060d5434619948899b416a8136545b79cd112051543212abe8ce34a30c1f868c633a3f3288fd6c0ea775162daf2eea15ca539a352c9bdb55ee336b20
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.9.1.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.9.1.ebuild
new file mode 100644
index 000000000000..fcbce5b78daf
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer messages and services for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"