summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-19 15:00:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-19 15:00:49 +0100
commit6548ce6eab27890ee1e2ba81caaa2f98d738b3b7 (patch)
tree8bd13b3b913a10ecbac37a9147a26a853644067f /dev-ros/gencpp/gencpp-0.5.4.ebuild
parentdev-ros/python_qt_binding: bump to 0.2.18 (diff)
downloadgentoo-6548ce6eab27890ee1e2ba81caaa2f98d738b3b7.tar.gz
gentoo-6548ce6eab27890ee1e2ba81caaa2f98d738b3b7.tar.bz2
gentoo-6548ce6eab27890ee1e2ba81caaa2f98d738b3b7.zip
dev-ros/gencpp: bump to 0.5.4
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/gencpp/gencpp-0.5.4.ebuild')
-rw-r--r--dev-ros/gencpp/gencpp-0.5.4.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/gencpp/gencpp-0.5.4.ebuild b/dev-ros/gencpp/gencpp-0.5.4.ebuild
new file mode 100644
index 000000000000..bd58a6c856e6
--- /dev/null
+++ b/dev-ros/gencpp/gencpp-0.5.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/gencpp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS C++ message definition and serialization generators"
+HOMEPAGE="http://wiki.ros.org/gencpp"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"