summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-25 09:16:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-25 10:56:35 +0200
commit84b742c7f8b2a4ec0bd5fb8ca48b542065077647 (patch)
treec17a1dd9a21dcb745bfafa1f34f07aa53ae932c7 /dev-ros/genpy/genpy-0.6.0.ebuild
parentsys-apps/ipmitool: Removed old. (diff)
downloadgentoo-84b742c7f8b2a4ec0bd5fb8ca48b542065077647.tar.gz
gentoo-84b742c7f8b2a4ec0bd5fb8ca48b542065077647.tar.bz2
gentoo-84b742c7f8b2a4ec0bd5fb8ca48b542065077647.zip
dev-ros/genpy: bump to 0.6.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.0.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/genpy/genpy-0.6.0.ebuild b/dev-ros/genpy/genpy-0.6.0.ebuild
new file mode 100644
index 000000000000..e18cd2aa843c
--- /dev/null
+++ b/dev-ros/genpy/genpy-0.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="http://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"