summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-24 15:44:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-24 15:44:42 +0200
commit7741f4ae0cd655ae4994e5933ba9f8ef04e65c90 (patch)
treee1ecf51286e6094000278af5f010b78487205f4b /dev-ros/genpy
parentdev-ros/rosconsole: bump to 1.14.2 (diff)
downloadgentoo-7741f4ae0cd655ae4994e5933ba9f8ef04e65c90.tar.gz
gentoo-7741f4ae0cd655ae4994e5933ba9f8ef04e65c90.tar.bz2
gentoo-7741f4ae0cd655ae4994e5933ba9f8ef04e65c90.zip
dev-ros/genpy: bump to 0.6.14
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/genpy')
-rw-r--r--dev-ros/genpy/Manifest1
-rw-r--r--dev-ros/genpy/genpy-0.6.14.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/genpy/Manifest b/dev-ros/genpy/Manifest
index 5a3b7110bd96..bf53a0c05714 100644
--- a/dev-ros/genpy/Manifest
+++ b/dev-ros/genpy/Manifest
@@ -1 +1,2 @@
DIST genpy-0.6.11.tar.gz 53128 BLAKE2B c0c6d9aa8d713e873a5cbceda8763c23e4b6259f5708be1575c4eae600b3f96bd8f05cda281711c799a0a4e00d69623ed0ddcb7812b4894d7c45717121f51c00 SHA512 267391cce6119085ae974f00fa4a33767b2b62a5d61bd290b3d2164cee275ce88b21d124b2da9ca9d85ac6a3a030ceddef766be34fba9c0d57ba26d6e1e41186
+DIST genpy-0.6.14.tar.gz 53964 BLAKE2B ff1503a56fdb07a5165d2891589450e3b40e85f68d541990828959b8d7f0e440091d77fd0bb4ac70fa0e39114b366c061e8d03979482539d2e5ca6cc3ff15b8c SHA512 5ce357ef41d2c06025ca2a06ca4111baf0d3b92dbdf877ea0ce5515d516d9e0fa46171057293ba96d5b55c5fa32b7c24ef28cfcd45be8bf9c3d73302feec6957
diff --git a/dev-ros/genpy/genpy-0.6.14.ebuild b/dev-ros/genpy/genpy-0.6.14.ebuild
new file mode 100644
index 000000000000..a5796a02b2e9
--- /dev/null
+++ b/dev-ros/genpy/genpy-0.6.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="https://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyyaml[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )
+"
+PATCHES=( "${FILESDIR}/yaml.patch" )