summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:52:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:52:22 +0200
commit3a3f5f9bb456ed8d1373c9aa6314fda9a6fe9140 (patch)
treeef7a58731bacc4d5399bb047b0bc6c632eda01c6 /dev-ros/geodesy/geodesy-9999.ebuild
parentdev-ros/geographic_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-3a3f5f9bb456ed8d1373c9aa6314fda9a6fe9140.tar.gz
gentoo-3a3f5f9bb456ed8d1373c9aa6314fda9a6fe9140.tar.bz2
gentoo-3a3f5f9bb456ed8d1373c9aa6314fda9a6fe9140.zip
dev-ros/geodesy: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/geodesy/geodesy-9999.ebuild')
-rw-r--r--dev-ros/geodesy/geodesy-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
new file mode 100644
index 000000000000..a514643d3244
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"