summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-08 09:37:21 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-08 09:37:21 +0100
commit74ae81e801605351db96a162ab53bbdf0c0fe315 (patch)
tree5d65217aee7f32c92da913623d821408a2dac8c9 /dev-ros/geometric_shapes/geometric_shapes-0.4.4.ebuild
parentsys-process/htop: Bump to version 2.0.1 (diff)
downloadgentoo-74ae81e801605351db96a162ab53bbdf0c0fe315.tar.gz
gentoo-74ae81e801605351db96a162ab53bbdf0c0fe315.tar.bz2
gentoo-74ae81e801605351db96a162ab53bbdf0c0fe315.zip
dev-ros/geometric_shapes: bump to 0.4.4
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/geometric_shapes/geometric_shapes-0.4.4.ebuild')
-rw-r--r--dev-ros/geometric_shapes/geometric_shapes-0.4.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/geometric_shapes/geometric_shapes-0.4.4.ebuild b/dev-ros/geometric_shapes/geometric_shapes-0.4.4.ebuild
new file mode 100644
index 000000000000..bbc8126acf3a
--- /dev/null
+++ b/dev-ros/geometric_shapes/geometric_shapes-0.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/geometric_shapes"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Generic definitions of geometric shapes and bodies"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ media-libs/qhull
+ media-libs/assimp
+ sci-libs/octomap
+ dev-ros/random_numbers
+ dev-ros/resource_retriever
+ dev-ros/eigen_stl_containers
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+ ros-catkin_src_prepare
+}