summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-31 13:24:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-31 15:09:11 +0200
commitce508e495776c92724995ceebf9d7726facd1953 (patch)
tree6ef81c34737dc72bffb31365af9de4199e4e7a3c /dev-ros/global_planner/global_planner-1.16.1.ebuild
parentdev-ros/fake_localization: Bump to 1.16.1. (diff)
downloadgentoo-ce508e495776c92724995ceebf9d7726facd1953.tar.gz
gentoo-ce508e495776c92724995ceebf9d7726facd1953.tar.bz2
gentoo-ce508e495776c92724995ceebf9d7726facd1953.zip
dev-ros/global_planner: Bump to 1.16.1.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/global_planner/global_planner-1.16.1.ebuild')
-rw-r--r--dev-ros/global_planner/global_planner-1.16.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/global_planner/global_planner-1.16.1.ebuild b/dev-ros/global_planner/global_planner-1.16.1.ebuild
new file mode 100644
index 000000000000..53f5c3324f95
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.16.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+
+ dev-ros/angles
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"