summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:46:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:02:02 +0200
commit2b3f9643bce32bc9490077ec42a259350a328cfa (patch)
treeea0c61120afeacbc02e5749302d334a70247f2fa /dev-ros/global_planner
parentdev-ros/map_server: Remove old (diff)
downloadgentoo-2b3f9643bce32bc9490077ec42a259350a328cfa.tar.gz
gentoo-2b3f9643bce32bc9490077ec42a259350a328cfa.tar.bz2
gentoo-2b3f9643bce32bc9490077ec42a259350a328cfa.zip
dev-ros/global_planner: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/global_planner')
-rw-r--r--dev-ros/global_planner/global_planner-1.17.0.ebuild10
-rw-r--r--dev-ros/global_planner/global_planner-9999.ebuild12
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-ros/global_planner/global_planner-1.17.0.ebuild b/dev-ros/global_planner/global_planner-1.17.0.ebuild
index cc0651737472..fc09b44f71a5 100644
--- a/dev-ros/global_planner/global_planner-1.17.0.ebuild
+++ b/dev-ros/global_planner/global_planner-1.17.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -17,9 +16,7 @@ IUSE=""
RDEPEND="
>=dev-ros/costmap_2d-1.16
dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/nav_core
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/navfn
dev-ros/pluginlib
dev-ros/roscpp
@@ -29,6 +26,9 @@ RDEPEND="
dev-libs/console_bridge:=
dev-ros/angles
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/global_planner/global_planner-9999.ebuild b/dev-ros/global_planner/global_planner-9999.ebuild
index 53f5c3324f95..fc09b44f71a5 100644
--- a/dev-ros/global_planner/global_planner-9999.ebuild
+++ b/dev-ros/global_planner/global_planner-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -17,9 +16,7 @@ IUSE=""
RDEPEND="
>=dev-ros/costmap_2d-1.16
dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/nav_core
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/navfn
dev-ros/pluginlib
dev-ros/roscpp
@@ -29,6 +26,9 @@ RDEPEND="
dev-libs/console_bridge:=
dev-ros/angles
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"