summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-28 15:49:48 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-28 15:56:18 +0200
commitdbca79a04a09ed0c80f68ff7171658d92e6817c4 (patch)
tree5f538b40bd14e268259cead25e4784241ff7591f /dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild
parentdev-ros/hector_imu_tools: Bump to 0.3.5. (diff)
downloadgentoo-dbca79a04a09ed0c80f68ff7171658d92e6817c4.tar.gz
gentoo-dbca79a04a09ed0c80f68ff7171658d92e6817c4.tar.bz2
gentoo-dbca79a04a09ed0c80f68ff7171658d92e6817c4.zip
dev-ros/hector_map_server: Bump to 0.3.5.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild')
-rw-r--r--dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild b/dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild
new file mode 100644
index 000000000000..51846160109b
--- /dev/null
+++ b/dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Service for retrieving the map, as well as for raycasting based obstacle queries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/hector_map_tools
+ dev-ros/hector_marker_drawing
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+"
+DEPEND="${RDEPEND}"