summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-28 19:19:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-28 19:23:55 +0200
commit00d9a1c67ed21365368464b9ff9738ce68620b34 (patch)
tree79ee33d9d57718a6983b6ead7227d90f35f3e278 /dev-ros/hector_mapping/files
parentdev-ros/laser_filters: bump to 1.8.7 (diff)
downloadgentoo-00d9a1c67ed21365368464b9ff9738ce68620b34.tar.gz
gentoo-00d9a1c67ed21365368464b9ff9738ce68620b34.tar.bz2
gentoo-00d9a1c67ed21365368464b9ff9738ce68620b34.zip
dev-ros/hector_mapping: fix build with boost 1.70
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_mapping/files')
-rw-r--r--dev-ros/hector_mapping/files/boost170.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/files/boost170.patch b/dev-ros/hector_mapping/files/boost170.patch
new file mode 100644
index 000000000000..89bc05d2f7da
--- /dev/null
+++ b/dev-ros/hector_mapping/files/boost170.patch
@@ -0,0 +1,13 @@
+Index: hector_mapping/CMakeLists.txt
+===================================================================
+--- hector_mapping.orig/CMakeLists.txt
++++ hector_mapping/CMakeLists.txt
+@@ -7,7 +7,7 @@ project(hector_mapping)
+ find_package(catkin REQUIRED COMPONENTS roscpp nav_msgs visualization_msgs tf message_filters laser_geometry tf_conversions message_generation)
+
+ ## System dependencies are found with CMake's conventions
+-find_package(Boost REQUIRED COMPONENTS thread signals)
++find_package(Boost REQUIRED COMPONENTS thread)
+ include_directories(${Boost_INCLUDE_DIRS})
+
+ # Find Eigen3 (from http://wiki.ros.org/jade/Migration)