summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 21:06:26 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 21:35:24 +0100
commit91a7d44510c1e1a0caa8a11045963c6935b758fe (patch)
tree9e8c7a8bf6ad6abf5cebfea17a588ba31adea9b0 /dev-ros/hector_mapping/hector_mapping-0.5.1.ebuild
parentdev-ros/hector_imu_attitude_to_tf: Bump to 0.5.1. (diff)
downloadgentoo-91a7d44510c1e1a0caa8a11045963c6935b758fe.tar.gz
gentoo-91a7d44510c1e1a0caa8a11045963c6935b758fe.tar.bz2
gentoo-91a7d44510c1e1a0caa8a11045963c6935b758fe.zip
dev-ros/hector_mapping: Bump to 0.5.1.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_mapping/hector_mapping-0.5.1.ebuild')
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.5.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/hector_mapping-0.5.1.ebuild b/dev-ros/hector_mapping/hector_mapping-0.5.1.ebuild
new file mode 100644
index 000000000000..becdf3842966
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM that can be used without odometry and on platforms that exhibit roll/pitch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"