summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-28 14:56:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-28 14:56:27 +0200
commit5aac6f55d35458f0e2effe16d81b2e294944b30d (patch)
tree29578bc058c2019202b80345513f1a0dbe9cd9a9 /dev-ros/hector_mapping/hector_mapping-9999.ebuild
parentdev-ros/hector_map_server: Initial import. Ebuild by me. (diff)
downloadgentoo-5aac6f55d35458f0e2effe16d81b2e294944b30d.tar.gz
gentoo-5aac6f55d35458f0e2effe16d81b2e294944b30d.tar.bz2
gentoo-5aac6f55d35458f0e2effe16d81b2e294944b30d.zip
dev-ros/hector_mapping: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/hector_mapping/hector_mapping-9999.ebuild')
-rw-r--r--dev-ros/hector_mapping/hector_mapping-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/hector_mapping-9999.ebuild b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
new file mode 100644
index 000000000000..c25585b63762
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"