summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:53:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:53:16 +0200
commitbf3d1f71ccc8c22559a51b0b8002e8fb185b6157 (patch)
tree20714afaa2163391d7fb4ffab9433588667f843f /dev-ros/hector_pose_estimation_core
parentdev-ros/geodesy: Initial import. Ebuild by me. (diff)
downloadgentoo-bf3d1f71ccc8c22559a51b0b8002e8fb185b6157.tar.gz
gentoo-bf3d1f71ccc8c22559a51b0b8002e8fb185b6157.tar.bz2
gentoo-bf3d1f71ccc8c22559a51b0b8002e8fb185b6157.zip
dev-ros/hector_pose_estimation_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/hector_pose_estimation_core')
-rw-r--r--dev-ros/hector_pose_estimation_core/Manifest1
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.2.0.ebuild28
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild28
-rw-r--r--dev-ros/hector_pose_estimation_core/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation_core/Manifest b/dev-ros/hector_pose_estimation_core/Manifest
new file mode 100644
index 000000000000..bb99c54d8331
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/Manifest
@@ -0,0 +1 @@
+DIST hector_localization-0.2.0.tar.gz 70999 SHA256 e0b01a8d1d285086e4bb738346f5d37ce188f12197bb10e75d66ac0770fc2f18 SHA512 5eab4f1861bbf1f755595700b9cb7e7f3fd1231ac9fe95f7a6f9f22c6d96045ebcecdf01b81464888b8a263fab585eb7d19682b1cc5aab6fa8809f25e7913739 WHIRLPOOL af642d3458d380c18985aa88e10625b4e7f0ae94a8bfaf9d8d4f1e38fa764785a9c95d551c4b0412c0c91649d8d3768a8cc4774fa761b8fce6ca7d21db374dd7
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.2.0.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.2.0.ebuild
new file mode 100644
index 000000000000..64f702c77b2e
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extended Kalman Filter (EKF) that estimates the 6DOF pose of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostime
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
new file mode 100644
index 000000000000..64f702c77b2e
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extended Kalman Filter (EKF) that estimates the 6DOF pose of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostime
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_pose_estimation_core/metadata.xml b/dev-ros/hector_pose_estimation_core/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>